centos libvert vm network ne peut pas get l'adresse IP

J'ai une machine hôte exécutant centos 6.2 et elle possède 2 VM utilisant libvirt. J'ai tout fonctionné, mais j'ai eu une panne de courant et maintenant l'hôte a une connectivité, mais la machine virtuelle ne peut pas avoir une adresse IP lorsqu'elle survient et n'a pas de connectivité réseau. J'essaie d'utiliser un adaptateur réseau ponté pour qu'ils se connectent.

ifconfig ressemble à ceci:

em1 Link encap:Ethernet HWaddr 84:2B:2B:58:4C:AD inet addr:192.168.1.38 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::862b:2bff:fe58:4cad/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Mesortingc:1 RX packets:328369 errors:0 dropped:2 overruns:0 frame:0 TX packets:228167 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:38114989 (36.3 MiB) TX bytes:267087066 (254.7 MiB) em2 Link encap:Ethernet HWaddr 84:2B:2B:58:4C:AE inet6 addr: fe80::862b:2bff:fe58:4cae/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Mesortingc:1 RX packets:227338 errors:0 dropped:1178 overruns:0 frame:0 TX packets:31 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:29134179 (27.7 MiB) TX bytes:2731 (2.6 KiB) lo Link encap:Local Loopback inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Mesortingc:1 RX packets:193026 errors:0 dropped:0 overruns:0 frame:0 TX packets:193026 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:262903768 (250.7 MiB) TX bytes:262903768 (250.7 MiB) vif1.0 Link encap:Ethernet HWaddr FE:FF:FF:FF:FF:FF inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Mesortingc:1 RX packets:29 errors:0 dropped:0 overruns:0 frame:0 TX packets:275 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:32 RX bytes:5774 (5.6 KiB) TX bytes:78680 (76.8 KiB) vif2.0 Link encap:Ethernet HWaddr FE:FF:FF:FF:FF:FF inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Mesortingc:1 RX packets:20 errors:0 dropped:0 overruns:0 frame:0 TX packets:158 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:32 RX bytes:3662 (3.5 KiB) TX bytes:41564 (40.5 KiB) virbr0 Link encap:Ethernet HWaddr FE:FF:FF:FF:FF:FF inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Mesortingc:1 RX packets:49 errors:0 dropped:0 overruns:0 frame:0 TX packets:74 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:9436 (9.2 KiB) TX bytes:11432 (11.1 KiB) 

Em1 est mon principal connecteur filaire et virbr0 est la connection en pont.

[root @ localhost network-scripts] # ​​route ip

 default via 192.168.1.1 dev em1 proto static 192.168.1.0/24 dev em1 proto kernel scope link src 192.168.1.38 mesortingc 1 

[scripts réseau root @ localhost] # brctl show

 bridge name bridge id STP enabled interfaces virbr0 8000.feffffffffff no vif1.0 vif2.0 

Lorsque j'essaie de faire un ping via mon pont, il échoue:

  ping -Ivirbr0 192.168.1.1 PING 192.168.1.1 (192.168.1.1) from 192.168.1.38 virbr0: 56(84) bytes of data. From 192.168.1.38 icmp_seq=1 Destination Host Unreachable 

Lorsque je redémarre mon réseau, je reçois cette erreur:

 service network restart Shutting down interface virbr0: [FAILED] Shutting down interface em1: Device state: 3 (disconnected) [ OK ] Shutting down interface em2: [ OK ] Shutting down loopback interface: [ OK ] Bringing up loopback interface: [ OK ] Bringing up interface Wired_connection_1: Active connection state: activating Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/61 state: activated Connection activated [ OK ] Bringing up interface em1: Active connection state: activating Active connection path: /org/freedesktop/NetworkManager/ActiveConnection/64 state: activated Connection activated [ OK ] Bringing up interface virbr0: Determining IP information for virbr0...PING 192.168.1.1 (192.168.1.1) from 192.168.1.38 virbr0: 56(84) bytes of data. --- 192.168.1.1 ping statistics --- 4 packets transmitted, 0 received, +4 errors, 100% packet loss, time 3005ms pipe 4 failed. [FAILED] 

Auparavant, avec ce server, j'avais ce problème: le server centos avec les machines virtuelles, par exemple, ne pouvait pas se connecter, mais vms fonctionne bien et a réussi à le réparer avec aide, mais peut-être que certaines des corrections que j'ai causées ont provoqué des problèmes après le redémarrage.

Aucune suggestion?

One Solution collect form web for “centos libvert vm network ne peut pas get l'adresse IP”

Il semble que vous avez NetworkManager gérant votre connection. Sur RHEL6, NetworkManager doit être désactivé lorsqu'il exécute une connection en pont avec libvirt. Essayez de le désactiver et de redémarrer votre système.

Si vous ne pouvez pas le désactiver dans l'set du système, vous pouvez éditer les files d'interface réseau sous /etc/sysconfig/network-scripts/ et insert la ligne

 NM_CONTROLLED=no 

dans les interfaces physiques et ponctuelles

  • Ordinateur hôte Ping installé à partir d'Ubuntu sur la boîte virtuelle
  • La meilleure pratique pour la configuration des groupes de ports uplink vmware dv?
  • Comment puis-je returnner le nom d'hôte d'un sous-domaine vers un nom de domaine différent?
  • Détectez si une carte réseau est une carte réseau virtuelle (docker / veth / etc) dans Linux / bsd
  • Définir une adresse IP par site Web sur un seul server Linux?
  • Changer de domaine (vhost?) Sur l'hébergement simple Gandi
  • Réseau ponté KVM comme dans la boîte virtuelle
  • Windows XP insiste lors de la reconnection au lecteur réseau au démarrage (Stop It)
  • Une virtualhost devrait-elle toujours utiliser le domaine nu comme nom de serveur?
  • La boîte Rapack réemballée (Vbox) ne permettra pas ssh après les imports ultérieures
  • Impossible de faire un ping entre l'hôte ESXi et le stockage Netapp sur le même commutateur
  • Les astuces du serveur de linux et windows, tels que ubuntu, centos, apache, nginx, debian et des sujets de rĂ©seau.