Comment installer PHP à partir de la source avec le dernier paquet cURL sur Linux?

Je dois simplement utiliser la dernière version de cURL (7.21.3) avec PHP sur mon serveur web. (A faire avec des corrections de bugs spécifiques)

Il n'est pas disponible par défaut sur les référentiels variant Linux les plus récents. (Natty Narwhal par Ubuntu est le seul et il est toujours en phase bêta) – donc je ne peux pas simplement exécuter "aptitude install php5-curl" ou similaire pour l'obtenir (la dernière version de CURL) installée.

Comment pourrait-on envisager d'installer les derniers paquets PHP + cURL?

Est-il aussi simple que de changer le fichier de téléchargement de CURL dans un dépôt quelque part? (C.-à-d. Modifier l'entrée d'un fichier texte à partir de http://curl.haxx.se/download/curl-7.21.0.tar.gz vers http://curl.haxx.se/download/curl-7.21.3. Tar.gz ou quelque chose …?)

Fondamentalement, j'ai besoin de la toute dernière bibliothèque cURL s'exécutant avec PHP sur Linux. Comment allez-vous personnellement faire cela?

Ajouter le référentiel natty:

$sudo echo "deb http://us.archive.ubuntu.com/ubuntu/ natty main universe multiverse" >> /etc/apt/sources.list $sudo apt-get update 

Créer / etc / apt / preferences (changer lucid, à votre version):

 Package: * Pin: release a=natty Pin-Priority: -10 Package: * Pin: release a=lucid Pin-Priority: 900 

Installez le dernier php5-curl:

 $sudo apt-get install -t natty php5-curl 

Test ( curl_version ):

 $php -i | grep -i curl cURL Information => 7.21.3 php -r 'var_dump(curl_version());' 

Ou téléchargez les codes source php5 et curl et créez.