Conflit d'adresse IP avec routeur / pare-feu

J'ai eu des problèmes de propriété intellectuelle avec ma boîte locale depuis quelques mois maintenant. Habituellement, quand il commence à agir, je n'ai pas la patience de l'examiner, alors je viens de déposer sur DHCP, mais ce matin, j'ai finalement décidé de comprendre ce qui se passe.

Je suis sur un réseau qui possède 192.2.40.1 comme passerelle et est un sous-réseau 255.255.254.0 (donc la plage IP est 192.2.40.1-192.2.41.254). Mon adresse IP statique est 192.2.40.17. Nous avons un pare-feu / routeur Watchguard Fireware XTM qui se trouve sur 192.2.40.1. En outre, notre gamme DHCP est 192.2.41.200-192.2.41.254

Le problème est que, de time en time, je perds ma connection réseau, et lorsque j'essaie de me reconnecter, j'ai des erreurs concernant un conflit d'adresse IP. Nous sums très ssortingctes quant à la documentation des adresses IP ici, alors j'ai trouvé assez bizarre que quelqu'un d'autre utiliserait mon adresse IP. J'ai fait quelques balayages réseau, j'ai vérifié mes loggings DNS et DHCP, et je n'ai trouvé rien en utilisant 192.2.40.17 (en dehors de mon ordinateur).

En saisissant les pailles, j'ai couru "arp-a" pour vérifier si cela pourrait me donner des informations. Curieusement, c'est ce que j'ai vu (note: je suis sur DHCP en ce moment):

C:\Users\jwegner>arp -a Interface: 192.2.41.107 --- 0xa Internet Address Physical Address Type 192.2.40.1 00-90-7f-42-3f-30 dynamic 192.2.40.17 00-90-7f-42-3f-30 dynamic //Truncated, because the rest is not important 

Intéressant: il semble que mon ordinateur local affiche 192.2.40.1 et 192.2.40.17 comme le même périphérique. J'ai vérifié cette adresse MAC, et c'est bien l'adresse MAC pour notre pare-feu / routeur. J'ai effacé mon cache d'arp, pensant que quelque chose a été transformé quelque part. J'ai ensuite fait un ping 192.2.40.17 pour recache l'arp, et arp -a output the same chose.

Il n'y a rien dans mon pare-feu / routeur qui le ferait prendre en charge l'adresse 192.2.40.17. En outre, si je ping 192.2.40.17, je ne reçois rien, alors je dois get une sorte de faux positif ici. Des idées sur ce qui pourrait causer cela?

S'il s'agit d'un réseau privé, vous devez passer à une plage IP non rouvertible. 10.0.0.x ou 192.168.1.x, pour réduire la confusion à la fois pour vous et les liens de l'extérieur.

On dirait qu'il s'est assigné une adresse? Vérifiez les messages DHCP pour l'affectation après avoir réinitialisé tout. Peut-être aider à diagnostiquer ce qui se passe.

D'abord, vous devez passer au réseau privé. Après cela, la bonne façon de résoudre ce problème serait de configurer une capture de packages et de savoir d'où proviennent les packages ARP. Mieux vaut l'exécuter sur la command line et la laisser fonctionner en arrière-plan:

 dumpcap -f "arp" -w "C:\temp\arp.pcap" 

Je soupçonne que c'est une configuration incorrecte sur le routeur (probablement essayer de faire Proxy ARP de manière incorrecte!)

J'ai eu le même problème sur un conflit d'adresse IP VM, provenant de l'adresse MAC du pare-feu auquel il était connecté. J'ai fini par append une nouvelle NIC et supprimer l'ancien, qui a résolu le problème.