HP DL60 Gen9 ne démarre pas le operating system installé

J'ai un problème avec 2 servers HP DL60 Gen9. Ils contiennent chacun 2 x 500 G SATA HDD. J'ai utilisé Intelligent Provisioning pour créer un réseau RAID 1 à l'aide des disques durs, mais le premier problème que j'ai remarqué est pendant le process d'installation du système. Je vois toujours deux disques durs qui sont étranges. Quoi qu'il en soit, j'ai essayé les scénarios suivants (en utilisant un disque USB):

  • a installé CentOS 6 et créé un réseau RAID 1 pendant l'installation du operating system
  • installé CentOS 6 sans aucun tableau
  • a installé CentOS 7 et créé un tableau RAID 1 pendant l'installation du operating system
  • installé CentOS 7 sans aucun tableau
  • installé CentOS 7 à l'aide de RAID + LVM

Le problème est que, après l'installation, il ne démarre pas, en disant qu'aucun périphérique de démarrage approprié n'a été trouvé. J'ai trouvé Installer GNU / Linux Pas d'erreur de disque système – HP Smart Array

Malheureusement, j'utilise GRUB mais ça ne le trouve toujours pas. J'ai vu la réponse d'ewwhite requestr si une key USB a été utilisée (ce qui est le cas pour moi). Le problème est que je n'ai pas de graveur de DVD dans le bureau et il faudra 2 jours si j'en ai un. Le fait d'essayer une installation à partir d'un USB est-ce que cela pourrait causer ces problèmes? Merci d'avance.

METTRE À JOUR

Parlant de HP, je réinitialisais tout les parameters FACTORY (auparavant, je n'ai essayé que les parameters par défaut) et j'ai recréé le lecteur logique. Cela semble avoir corrigé le problème et je peux maintenant démarrer dans CentOS 7. Cependant, le problème restant est pourquoi je vois encore 2 lecteurs pendant le process d'installation, même si j'ai créé un réseau RAID 1 à l'aide de l'interface HP Smart Storage .

4 Solutions collect form web for “HP DL60 Gen9 ne démarre pas le operating system installé”

Retirez la key USB avant que le chargeur de démarrage ne soit installé pendant l'installation du operating system.

Vous avez peut-être écrit le chargeur de démarrage sur le mauvais périphérique. L'énumération SCSI change lorsque vous implémentez des périphériques USB au moment de l'installation; Par exemple, la key USB devient / dev / sda et pousse vos disques internes vers / dev / sdb.

Voir aussi: Proliant dl380p gen8 Démarrage Debian

Je peux être en retard pour cette fête – mais j'ai frappé exactement le même problème récemment et je suis tombé sur ce sujet, c'est l'une des questions relativement peu nombreuses sur ce point – j'étais en train d'installer Debian sur un server DL60 – et j'ai passé deux jours à ne rien faire. , jusqu'à ce que j'ai suivi une ligne de départ d'une autre question quelque part (je suis désolé, j'oublie où) – ce qui m'a conduit à la réponse vraiment simple ici:

Réglez "Activer SATA AHCI" sous "Options du système" dans le BIOS (à partir des parameters par défaut de démarrage (F9) pour le faire démarrer à partir du disque dur sous le contrôle Debian et non sur le contrôle HP. Si vous ne le faites pas, vous perdrez 2 jours comme Je viens de faire ….. et c'est littéralement le seul changement que je devais faire en fin de journée! Cela signifie que vous ignorez TOUT LE RAID RAID HP entièrement, mais vous utilisez toujours le côté UEFI de la vie comme En ce qui concerne Debian …

J'espère que ça aide quelqu'un

Andy

Vous avez mentionné: Cependant, le problème restant est la raison pour laquelle je vois toujours 2 lecteurs pendant le process d'installation même si j'ai créé un réseau RAID 1 à l'aide de l'interface HP Smart Storage.

Vous verrez 2 lecteurs même après la configuration RAID car CentOS ne peut pas détecter le pilote RAID. J'ai rencontré cela sur différents servers HP. Vous devrez charger le pilote lors de la configuration.

Confirmez votre model RAID Controller.

J'ai frappé la même chose en installant RHEL 7 sur un DL60. Apparemment, RHEL / Centos 7 est incompatible avec les pilotes Smart Array b140i sur les controllers HP Gen9. Voici comment finalement RHEL a été chargé sur le DL60:

  1. Téléchargez le pilote hpdsa (ou hpvsa) à partir de HP. Pour le mien, c'est un controller B140i: http://h20565.www2.hpe.com/hpsc/swd/public/detail?sp4ts.oid=7304563&swItemId=MTX_186b4a75315c4de1ae2e93ee94&swEnvOid=4176
  2. Sur une machine Linux, utilisez la command dd pour copyr sur un lecteur USB: dd if = hpdsa – .. x86_64.dd de = / dev / sdc1)
  3. Démarrez le DL60 en utilisant le disque RHEL / CentOS. Dans l'écran Option d'installation, appuyez sur 'e' pour éditer la command d'installation. Ajoutez 'modprobe.blacklist = ahci inst.dd' à la fin de la ligne qui démarre avec linuxefi: linuxefi / Images / pxeboot / vmlinuz inst.stage2 = hd: LABEL-RHEL-7.0 \ x20Server .x86_64 quiet modprobe.blacklist = ahci inst.dd
  4. À la «sélection du périphérique du disque conducteur», entrez «r» pour actualiser. Sélectionnez votre lecteur USB dans la list (sda1, etc.). Sélectionnez le 'hpdsa' dans la list des pilotes. Sélectionnez 'c' pour continuer.

http://h20565.www2.hpe.com/hpsc/doc/public/display?sp4ts.oid=3884098&docLocale=en_US&docId=mmr_kc-0135766

  • Sauver un Raid 1 d'un server dédié
  • protéger mes files de la racine
  • PPTP VPN sur un seul port
  • Getting Pango-WARNING: string UTF-8 invalide passée à pango_layout_set_text ()
  • Systemd redémarre le service s'il n'écoute pas un port
  • Partage des dossiers Ubuntu sur un routeur Linksys
  • Comment apprendre / maîsortingser (tutoriels) pour gérer un VPS? - nouvel user VPS
  • Existe-t-il une édition de server CentOS et une édition de bureau séparée?
  • Les astuces du serveur de linux et windows, tels que ubuntu, centos, apache, nginx, debian et des sujets de rĂ©seau.