IIS n'authentifiera pas l'user du domaine: 401.2

J'ai beaucoup de problèmes pour configurer l'authentification pour IIS correctement. J'ai un site SharePoint exécuté sous IIS 6.0 et le site Web IIS est configuré pour l'authentification Windows embeddede. Le server Web se trouve sur un domaine appelé STAGING , et la plupart de mes users sont un autre domaine appelé CORP . Les users de CORP ont des counts de domaine STAGING et peuvent se connecter au site SharePoint sur les domaines (par exemple, les users sont connectés à leurs posts de travail CORP et peuvent se connecter au site). Cependant, les users du domaine STAGING ne peuvent pas se connecter à partir du domaine STAGING . D'après ce que je comprends, les users du domaine STAGING devraient pouvoir accéder au site sans être invités à get des informations d'identification, mais ce n'est pas le cas. Même si, une fois que les informations d'identification sont inputs, le résultat est toujours un 401.

J'ai regardé la session HTTP dans Fiddler, et il semble que le server simple n'accepte pas les informations d'identification négociées envoyées par le browser client. Voici un logging abrégé:

 HTTP GET server /sites/mysite with headers: { } --> 401.2, with headers: { WWW-Authenticate: Negotiate, WWW-Authenticate: NTLM } HTTP GET server /sites/mysite with headers: { Authorization: Negotiate <digest1> } --> 401.1, with headers: { WWW-Authenticate: Negotiate <digest2> } HTTP GET server /sites/mysite with headers: { Authorization: Negotiate <digest3> } --> 401.1, with headers: { WWW-Authenticate: Negotiate <digest4> } 

Le cycle GET / 401.1 se répète 3 fois avant que le browser n'abandonne définitivement.

Je m'attends à ce que si j'avais tout configuré correctement, le client dans le domaine passerait simplement les informations d'identification et la vie serait bonne, mais ce n'est pas ce qui se passe, et la vie n'est pas bonne 🙁

Quelqu'un a-t-il des suggestions?

One Solution collect form web for “IIS n'authentifiera pas l'user du domaine: 401.2”

401.2 signifie généralement que IIS ne prend pas en charge le type d'authentification que vous essayez d'utiliser. Êtes-vous sûr que Windows Integrated Auth est activé?

Vérifiez les parameters IIS sur vos machines STAGING: le paramètre Authentification user / login dans les réglages de security (pour la zone dans laquelle votre site SharePoint se trouve …) doit être configuré pour "connection automatique avec le nom d'user et le mot de passe actuels" – ou, si votre site SharePoint se trouve dans la zone intranet, vous pouvez utiliser "connection automatique uniquement dans la zone intranet"

Consultez AuthDiag – il est conçu pour aider à diagnostiquer les erreurs d'authentification.

  • Serveurs membres Active Directory dans la DMZ
  • Authentification Ldap pour Windows Serveurs autonomes
  • Outlook Demander le mot de passe du server Exchange dans l'environnement de domaine
  • "Nom d'user inconnu ou mot de passe incorrect" lorsque je lance ADUC
  • Configuration d'IIS pour l'authentification kerberos entre forêts
  • Mettre à niveau Ubuntu 11.10 vers 12.04: Apache ne fonctionne plus
  • Problème de stratégie d'authentification Windows Server Windows uniquement
  • Configurez l'authentification Windows de base pour vous connecter à SQL Server 2008 à partir d'un petit réseau de confiance
  • Authentification Windows embeddede avec Chrome et FireFox
  • Pourquoi SMB sur Mac OS X Server 5.2 (Sierra) fonctionne-t-il avec les counts locaux mais pas les counts de directory réseau?
  • Risques de la délégation de Kerberos
  • Les astuces du serveur de linux et windows, tels que ubuntu, centos, apache, nginx, debian et des sujets de réseau.