Impossible d'installer Valgrind sur OS X

J'ai téléchargé le plus récent Valgrind et l'ai extrait.

je cours

./configure --prefix=/usr/local/valgrind make 

qui me donne

 make: *** No targets specified and no makefile found. Stop. 

je cours

 make install 

Ça me donne

 make: Nothing to be done for `install'. 

Comment pouvez-vous installer Valgrind sur le plus récent OS X?

    2 Solutions collect form web for “Impossible d'installer Valgrind sur OS X”

    La version 3.4.1 est incompatible avec Mac OS X pour autant que je sache. Comme ce n'était que plus récemment (mai 2009 – 3.4.1 a été publié en février 2009), que Valgrind a reçu une " compatibilité ". Le port Mac OS X est indiqué dans la page Mac OS X:

    Ce port est non surveillé et INCOMPLETE et BUGGY

    Vous devrez get le dernier de svn comme documenté sur valgrind.org :

     svn co svn://svn.valgrind.org/valgrind/trunk valgrind cd valgrind ./autogen.sh ./configure --prefix=... make make install 

    Vous aurez également besoin d' autoconf et d' automake qui peuvent être facilement installés à l'aide de MacPorts

    Pour déboguer la danse "configure, make, make install":

    Avez-vous vu quelle erreur survenue lors de la phase de configure ? Vous ne pouvez pas make (et ensuite installer en utilisant make install ) à less que la configuration ne fonctionne correctement.

    Les instructions indiquent que vous devez faire ./autogen.sh avant de make .

    Les astuces du serveur de linux et windows, tels que ubuntu, centos, apache, nginx, debian et des sujets de réseau.