Je pense que j'ai résolu la dépendance, le régime ne fonctionne pas

J'ai mis à jour le post de paiement EPEL afin d'installer le référentiel Remi afin de mettre à niveau PHP vers 3.5.4 afin de mettre à niveau le document civicrm (sur un VPS CentOS 6.7 exécutant un site de production et son site de développement).

repolist:

repo id repo name status base CentOS-6 - Base 6,575 epel Extra Packages for Enterprise Linux 6 - x86_64 12,126 extras CentOS-6 - extras 52 updates CentOS-6 - Updates 1,472 repolist: 20,225 

mais rpm -Uvh remi-release-6.rpm donne

 warning: remi-release-6.rpm: Header V3 DSA/SHA1 Signature, key ID 00f97f56: NOKEY error: Failed dependencies: epel-release >= 6 is needed by remi-release-6.6-2.el6.remi.noarch 

Outre le fait que je dois find et installer une key GPG pour Remi, pourquoi la version 6 échoue-t-elle une dépendance qui dit GE 6?

Il est probable que vous avez installé les référentiels EPEL en modifiant à la main un file approprié dans /etc/yum.repos.d . Cela est parfaitement correct en ce qui concerne l'obtention des packages EPEL sur votre système, mais pour un usage plus sophistiqué, il tombe un peu.

Le logiciel REMI sait qu'il a besoin de packages EPEL, de sorte que l'installation dépend de ceux qui sont configurés. La manière recommandée d'activer les packages EPEL sur votre système consiste à installer le RPM de epel-release . Cela contient la key de GPG pertinente, le file de count-relais yum, et pas beaucoup d'autre, mais sa présence est un moyen rapide pour les packages de savoir que les packages EPEL seront disponibles si nécessaire.

Si vous installez le RPM de epel-release , non seulement votre système pourra-t-il accéder aux packages EPEL, comme il le peut déjà, mais d' autres logiciels savent qu'ils peuvent countr sur la disponibilité d'EPEL , qu'ils ne peuvent actuellement pas.