Le server Domino toujours échoue à envoyer le courrier électronique SMTP lors de la première tentative

Dans nos journaux, nous trouvons ci-dessous:

Router: No messages transferred to fakedomain.com (host mx.fakedomain.com) via SMTP: The server is not responding. The server may be down or you may be experiencing network problems. Contact your system administrator if this problem persists. 

Ce qui suit est suivi de:

 Router: Transferring mail to domain fakedomain.com (host mx.fakedomain.com [111.111.111.111]) via SMTP Router: Message 12345678 transferred to mx.fakedomain.COM for recipient@fakedomain.com via SMTP Router: Transferred 1 messages to fakedomain.com (host mx.fakedomain.com) via SMTP 

Nos messages sortent normalement, mais nous voyons ce même problème TOUTES les connections que nous faisons. Je pense qu'il y a quelque chose qui ne va pas avec ma configuration, probablement avec un timeout d'attente, ou quelque chose de similaire, mais je n'ai pas pu le repérer correctement.

Cela ressemble à un problème que j'ai eu dans un context différent: pour découvrir la raison pour laquelle vous pourriez essayer ce qui suit:

Ouvrez un cmd sur le server, tapez les commands suivantes

 nslookup set type=mx fakedomain.com 

Et regardez les résultats: je parie, qu'il y aura des timeouts ou d'autres comportements étranges. Domino utilise cette méthode pour déterminer l'logging mx pour le domaine cible. Et si cette search doit durer, elle affichera l'erreur affichée, et réessayer … puis il obtient les valeurs mises en cache, et tout va bien.

Si la search mx est assez rapide, la résolution du nom dans une adresse IP pourrait être le problème.

Essayez les commands suivantes pour valider cela:

 nslookup mx.fakedomain.com 

Cela devrait vous donner l'adresse IP du mx-record. À quelle vitesse est cette search? Cette search de DNS pourrait également être faite avec un simple ping mx.fakedomain.com . Dans un cas, j'ai eu chaque échec de la première et de la seconde, mais réussit à pings où réussit … alors la même erreur serait sur la console.

Je suppose que c'est un problème de réseau et n'a rien à voir avec votre configuration de domino. Réparez le réseau et le domino sera réparé.

Vous pouvez essayer de modifier le MailTimeout dans votre notes.ini sur le server.

Syntaxe: MailTimeout = nombre de jours

Exemple: MailTimeout = 3

Mais soyez conscient que ce n'est pas la solution pour le problème qui est causé sur votre réseau. Cela aidera uniquement les courriels ne renvoyent directement à l'user. Si vous mettez également une semaine comme un timeout, cela pourrait confondre les users car les emails seront returnnés après de nombreux jours. Donc, la valeur maximale que vous devriez mettre ici devrait être 3 à mes yeux.

J'ai trouvé une solution:

Ouvrez un cmd sur le server, tapez les commands suivantes:

 set timeout = 55 

Cela a fonctionné pour moi.