Le server XEN ne transite pas le trafic vers DomU

Je collabore à ce problème depuis quelques heures maintenant et je ne trouve que le bon conseil.

Dom0 est un Debian Squeeze.

J'ai configuré un server Xen sur un Dom0 en utilisant apt-get.

Dom0 a l'ip 178.15.15.15. Le server est accessible et fonctionne bien. L'installation se déroule sans problèmes.

J'ai un sous-réseau supplémentaire / 29. J'ai configuré le premier ip du sous-réseau sur le Dom0 pour être ma passerelle par défaut pour mon DomU plus tard.

ip addr add 188.40.249.129/29 dev eth0

ip est activé et les réponses aux pings, aux connections ssh etc.

sysctl.conf ressemble à ceci:

net.ipv4.ip_forward=1

net.ipv4.conf.all.rp_filter=1

net.ipv6.conf.all.forwarding=1

net.ipv4.conf.default.proxy_arp=1

net.ipv4.icmp_echo_ignore_broadcasts=1

xend-config.sxp est défini sur:

(network-script network-route)

(vif-script vif-route)

La mise en place d'un DomU se poursuit également. J'ajoute l'adresse IP 188.40.249.131. Malheureusement, l'adresse IP ne répond pas à la sortie ou à l'arrivée.

Veuillez noter que ce ne sont pas les adresses IP réelles.

Merci pour toute aide!

Je viens de find la solution.

Debian prend en charge dans /etc/networks/interfaces une option appelée pointtopoint.

En ajoutant cette option avec la passerelle dans Dom0 et tous les DomU, le routing fonctionne.

Soyez informé que sur Dom0, vous devez mettre la passerelle par défaut et sur l'adresse IP de DomU de l'adresse IP sur le Dom0 dans le même sous-réseau.

Exemple: pointtopoint 10.xx1

vérifiez les règles d'avancement d'iptables. doit permettre à tout le trafic de vifX