les tasses ne seront pas installées

J'ai dû retirer des tasses de ma machine pour faire des tests. Je l'ai juste supprimé avec apt-get purge cups mais maintenant je ne peux pas l'installer à nouveau, donc je ne peux pas imprimer. Je n'ai jamais vu une telle erreur, quelqu'un peut-il me donner des explications sur ce qui se passe? (Je souhaite surtout apprendre et comprendre mon erreur, mais je l'ai googlé et il y a tellement de cas différents. J'utilise Ubuntu 10.04).

Lorsque j'essaie de l'installer avec apt-get install cups, j'obtiens ce résultat:

root@pc-desktop:/home/pc# apt-get install cups Reading package lists... Done Building dependency tree Reading state information... Done cups is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. 3 not fully installed or removed. After this operation, 0B of additional disk space will be used. Setting up cups (1.4.3-1ubuntu1.5) ... update-rc.d: warning: /etc/init.d/cups missing LSB information update-rc.d: see <http://wiki.debian.org/LSBInitScripts> /usr/sbin/cupsd: symbol lookup error: /usr/sbin/cupsd: undefined symbol: _httpReadGNUTLS cups: unable to start scheduler. invoke-rc.d: initscript cups, action "start" failed. dpkg: error processing cups (--configure): subprocess installed post-installation script returned error exit status 1 dpkg: dependency problems prevent configuration of ghostscript-cups: ghostscript-cups depends on cups; however: Package cups is not configured yet. dpkg: error processing ghostscript-cups (--configure): dependency problems - leaving unconfigured dpkg: dependency problems prevent configuration of cups-driver-gutenprint: cups-driver-gutenprint depends on cups (>= 1.3.0); however: Package cups is not configured yet. cups-driver-gutenprint depends on ghostscript-cups; however: Package ghostscript-cups is not configured yet. dpkg: error processing cups-driver-gutenprint (--configure): dependency problems - leaving unconfigured No apport report written because the error message indicates its a followup error from a previous failure. No apport report written because the error message indicates its a followup error from a previous failure. Errors were encountered while processing: cups ghostscript-cups cups-driver-gutenprint E: Sub-process /usr/bin/dpkg returned an error code (1) 

Et j'ai une nouvelle fois.

Quelqu'un at-il des indices? Je ne sais vraiment pas où je devrais commencer à chercher.
Merci beaucoup d'avance.
Pasortingck

4 Solutions collect form web for “les tasses ne seront pas installées”

hmmm essayez une sortie automatique après l'installation:

 sudo apt-get purge cups && sudo apt-get autoremove sudo apt-get update && sudo apt-get install cups 

Que diriez-vous

 apt-get install --reinstall cups 

Si votre CUPS est toujours installé, il semble que votre initscript soit borked. Avez-vous modifié manuellement votre script de démarrage CUPS ou les en-têtes LSB?

La réinstallation d'Ubuntu l'a fait. Un peu rude.

  • Impossible d'envoyer un courriel via Postfix SMTP via Mac Mail App
  • Ive got dkim = neutre (mauvaise version) header.i avec gmail et dkim = échec (type de clé inconnue) avec yahoo
  • KVM / QEMU: connectez-vous à VM sans GUI
  • Quelles sont les meilleures façons de vérifier la santé d'un server basé sur Debian
  • Nouveau RAID hdparm lent
  • Optimisez Apache pour les requests simultanées élevées
  • Puis-je changer un mot de passe user dans Linux à partir de la command line sans interactivité?
  • Comment configurer les servers de noms pour l'instance Amazon EC2
  • Volume Mount TrueCrypt avec NTFS sur command line Linux
  • Impossible d'get datatables du capteur IPMI
  • PHP-FPM Travailleurs en train de faire des packages php.ini en chargement?
  • Les astuces du serveur de linux et windows, tels que ubuntu, centos, apache, nginx, debian et des sujets de rĂ©seau.