Logiciel mort RAID CentOS 6

J'ai un réseau RAID 5 (avec LVM en haut) sur une boîte CentOS 6. Le tableau lui-même est une étagère de disque LSI StorageTek avec 14 lecteurs connectés au server avec un câble de canal de fibre.

Après avoir redémarré la machine, le réseau RAID ne sera pas remis en marche. Disk Utility dans Gnome déclare qu'il est "pas en cours d'exécution, partiellement assemblé".

J'ai couru mdadmin --assemble --scan , qui a déclaré:

 mdadm: /dev/md/:storagetek-1_0 assembled from 1 drive - not enough to start the array. mdadm: No arrays found in config file or automatically 

/ proc / mdstat dit:

 Personalities : [raid6] [raid5] [raid4] md127 : inactive sdf1[7] sdi1[4] sde1[8] sdj1[3] sdc1[10] sdg1[6] sdd1[9] sdn1[12] sdb1[11] sdm1[0] sda1[14] sdk1[2] 860171694 blocks super 1.2 unused devices: <none> 

Je suis assez nouveau pour gérer les arrays RAID sur Linux (pourriez-vous deviner?), J'ai donc atteint la limite de mes connaissances très limitées sur le sujet.

J'espère optimiste que c'est en train d'être reconstruit, mais de ce que j'ai vu, je doute.

Quelqu'un peut-il me donner un indice sur la façon de le réparer?

2 Solutions collect form web for “Logiciel mort RAID CentOS 6”

Ce n'est pas en cours de reconstruction; Dans l'affirmative, /proc/mdstat vous le dirait et ne vous dit pas inactive .

En regardant le message,

 mdadm: /dev/md/:storagetek-1_0 assembled from 1 drive - not enough to start the array. 

Je suppose que la machine ne voit que l'un des lecteurs sur l'étagère. (Ou peut-être ont-ils été renumérotés, mais je pense que mdadm est assez intelligent pour faire face à cela.) Je ne connais pas grand-chose sur le support de Linux FC et tellement, mais peut-être y mdadm -il un outil qui vous montre ce qu'il voit?

Aussi, exécutez définitivement dmesg pour voir s'il y a quelque chose sur le plateau, les lecteurs, RAID, etc. dans le journal du kernel.

Merci pour l'info. Je viens de rentrer après Noël. Les tests SMART suggèrent que / dev / sdl dans mon tableau a échoué, mais que / dev / sdh est correct. Je suppose que cela signifie que je dois replace / dev / sdl. Existe-t-il un moyen de faire la lumière sur le flash du lecteur ou quelque chose afin que je puisse m'assurer que je reçois le bon? À titre d'arrière-plan, ce problème a commencé lorsque j'ai supprimé un lecteur pour get le numéro de série pour order des pièces de rechange (ok, mauvaise idée avec le recul, mais j'ai supposé qu'ils étaient remplaçables à chaud). Je pense que ce qui s'est probablement passé, c'est que j'ai supprimé / dev / sdh et que / dev / sdl avait déjà échoué précédemment, ce qui a laissé le tableau avec 2 noeuds manquants, donc il a échoué. Comme / dev / sdh semble être correct, quelle est la bonne command pour la re-append au tableau?

  • Semodule -i doit-il être exécuté après chaque mise à jour de la stratégie SELinux?
  • Installer postgresql sur RHEL 5.6
  • Redhat container sur un moteur docker pur
  • Comment savoir à quelle référence berkley db openldap se réfère?
  • Qu'est-ce qui empêche l'user d'Apache de faire des connections sortantes?
  • Comment arrêter un startx en cours sur linux. Ne modifiez pas seulement inittab ou init3
  • Des centaines de connexions ssh échouées
  • Port de travail invisible pour lsof
  • Comment activer IPv6 Autoconfiguration avec adresse statique sous Linux (RHEL)
  • La meilleure façon de rendre RHSCL PHP disponible dans le monde
  • Envoi de journaux d'audit au server SYSLOG
  • Les astuces du serveur de linux et windows, tels que ubuntu, centos, apache, nginx, debian et des sujets de rĂ©seau.