Articles of debian

Réduire PID_MAX en toute security

J'ai un server dans un cluster qui connaissait une fuite de table de process. Étant donné que le développeur responsable du code n'était pas disponible pendant quelques jours, j'ai augmenté pid_max sur la machine comme suit: echo 4194303 > /proc/sys/kernel/pid_max Cela nous a acheté du time jusqu'à ce que le développeur puisse réparer son application […]

connectez-vous au server VPN tiers, mais ne l'utilisez pas comme itinéraire par défaut?

Je voudrais me connecter à un server VPN tiers dans Linux (par exemple, Debian Jessie) mais, par défaut, j'utilise mon interface eth0 lan comme itinéraire par défaut et je suis curieux de savoir comment y parvenir. J'utiliserais le routing des politiques ou les namespaces de réseau ou les jeux de règles pour sélectionner quand je […]

Directives Apache Commande: Global, Pre-VHost, ou dans les blocs d'annuaire

Je configure mon premier server virtuel à partir de zéro (le nom du fournisseur est supprimé mais c'est une «gouttelette»). J'ai utilisé WHM pendant un certain time et je pense que je le connais assez. Plus précisément, c'est une machine Debian 8, exécutant Apache 2.4 (il utilise apache.conf pas httpd.conf ) Quoi qu'il en soit, […]

Impossible de démarrer dans le logiciel RAID1 après une panne de disque

Aujourd'hui, après le redémarrage de mon server de données, j'ai été incapable de démarrer car l'un des lecteurs n'a plus été reconnu, il tourne toujours lorsque je le connecte et que je ne fais pas beaucoup de bruits étranges, à l'exception d'un très léger (type de silencieux) pendant quelques secondes. J'ai essayé de le connecter […]

KVM / QEMU: connectez-vous à VM sans GUI

Version courte (la solution est ci-dessous): J'ai un ordinateur Windows. J'ai un server Debian (sans environnement de bureau). J'ai une VM Ubuntu fonctionnant sur le server Debian via KVM / QEMU. Question: Comment puis-je me connecter à Ubuntu VM et démarrer le process d'installation? Version longue (la solution est ci-dessous): Situation J'ai une certaine expérience […]

Installez PostgreSQL sur Ubuntu sans le démarrer

Je souhaite installer PostgreSQL 8.4 (ou tout service) sur Ubuntu 10.4 (ou toute distro Linux) sans qu'il démarre dans le cadre de l'installation. En ce moment, quand je fais un sudo apt-get install postgresql-8.4 une partie du process d'installation est Starting PostgreSQL 8.4 database server [ OK ] Je ne veux vraiment pas que PostgreSQL […]

Instabilités avec interfaces ponctuelles et liées

J'ai publié hier pour get une configuration de travail avec plusieurs interfaces ponctuelles utilisées pour les machines virtuelles (KVM / libvirt). L'une des interfaces pontées utilise simplement eth3 comme ses ports tandis que la seconde (trafic public) utilise une interface Ethernet connectée. Cette configuration fonctionne mais pas tout le time! Je peux commencer un téléchargement […]

Impossible que PostgreSQL s'exécute dans Debian Lenny

J'essaie d'installer PostgreSQL 8.3 sur Debian Lenny (kernel 2.6.26-2-686) en utilisant le gestionnaire de packageages: sudo apt-get install postgresql-8.3 postgresql-client-8.3 postgresql-consortingb-8.3 postgresql-common Lors du deployment du package postgresql-common, l'avertissement suivant s'affiche: supported_versions: AVERTISSEMENT: version Debian inconnue: 5.0.4 Je me request si cela est lié au problème que je décris ci-dessous. Ensuite, j'essaie de lancer le […]

Apache + LDAP Auth: access à / échoué, raison: nécessiter des directives présentes et non Autoriser le gestionnaire

Ne peut pas résoudre celui-ci, voici mon .htaccess: AuthPAM_Enabled désactivé AuthType Basic AuthBasicProvider ldap AuthzLDAPAutoritaire sur AuthName "MESSAGE" Exiger le groupe ldap cn = CHANGER, cn = CHANGER AuthLDAPURL "ldap: // localhost / dc = CHANGÉ, dc = CHANGÉ? Uid? Sub? (ObjectClass = posixAccount)" AuthLDAPBindDN CHANGÉ AuthLDAPBindPassword CHANGÉ AuthLDAPGroupAtsortingbute memberUid AuthLDAPURL est correct, BindDN et […]

debian: la mise à jour de etch à lenny échoue

Le message d'erreur est: error processing /var/cache/apt/archives/debianutils_2.30_i386.deb (–unpack): trying to overwrite `/usr/sbin/add-shell', which is also in package passwd Comment puis-je résoudre ce problème? Je fais aptitude safe-upgrade ouptput de dpkg -S add-shell: passwd: /usr/sbin/add-shell