Articles of rpm

Comment mettre à jour unixODBC via yum sur EB awsLinux

En résumé, je dois mettre à jour unixODBC sur les instances PHP Elastic Beanstalk, de preference en utilisant yum, car il est assez facile à gérer via .ebextensions. AWS Linux: 64 bits Amazon Linux 2017.03 v2.4.2 exécutant PHP 7.0 Nécessité d'unixODBC: 2.3.1 sudo yum info unixODBC Installed Packages Name : unixODBC Arch : x86_64 Version […]

Impossible de mettre à jour le packageage avec YUM

J'essaie de mettre à jour un package openssl sur mon nœud. # yum update openssl-1.0.1e-60.el7.x86_64 Loaded plugins: product-id, rhnplugin, subscription-manager This system is receiving updates from RHN Classic or Red Hat Satellite. baseline_prd_channel | 871 B 00:00:00 baseline_prd_channel/primary | 1.7 MB 00:00:00 baseline_prd_channel 805/805 Resolving Dependencies –> Running transaction check —> Package openssl.x86_64 1:1.0.1e-42.el7_1.9 will […]

Créer un référentiel local avec toutes les dependencies à partir de rpm

J'ai un rpm personnalisé qui m'a été donné par un fournisseur qui a des dependencies qui sont tirées lors de l'installation. Je dois installer ce package sur un système de réseau fermé, de sorte que je ne peux pas accéder à internet pour rassembler les dependencies. Je peux cependant accéder à un server intermédiaire qui […]

/var/lib/rpm/__db.xxx files supprimez les alertes de mise à jour

Une équipe d'audit de security a mis en place une solution de gestion d'intergénération de files sur certains des servers linux gérés par la société avec laquelle je travaille. Ils nous interrogeaient sur les alertes qu'ils ont concernant les files /var/lib/rpm/__db.xxx qui sont supprimés et modifiés. Je dois leur donner la raison pour laquelle ces […]

Installation de Strongswan pour CentOS 7

Je souhaite utiliser IKEv2 VPN sur un CentOS 7. * VM et je souhaite authentifier les users avec notre server RADIUS. À l'heure actuelle, yum install strongswan command yum install strongswan pour installer le repo strongswan, mais il ne charge pas le plugin eap-radius par défaut. Existe-t-il un moyen de charger le plugin eap-radius en […]

Comment dégrader systemd en chapeau rouge

J'ai installé Systemd dans ma machine virtuelle: systemd.x86_64 systemd-libs.x86_64 systemd-python.x86_64 systemd-sysv.x86_64 Toute la version 219-30.el7_ 3.8 . Je dois le replace à la version 219-30.el7_ 3.6 Remarque: J'ai des RPM pour la version 3.6. Comment puis-je le faire? Ma VM n'a pas d'access externe.

Construire la database RPM "shadow"?

Disons que les responsables du server ne veulent pas que le logiciel de notre département soit installé à l'aide des packageages RPM. Parce qu'il requirejs des droits de super-user et qu'ils ont peur qu'il puisse gâcher leur système, etc. Nous devons donc déballer les tarballs vers /elsewhere/… , ce qui est une nuisance vraiment parce […]

Installez plusieurs versions du package rpm

J'ai besoin d'utiliser python2.5. Mais mon système (FC11) possède seulement python 2.6. Comment puis-je installer et utiliser plusieurs versions de python avec yum ou rpm? Ou peut-être dois-je comstackr python 2.6 à partir de sources?

Tomcat 6 on Centos 5 – seulement RPMs

Je passe à travers l'exercice de configuration de Tomcat 6 sur CentOS 5 en utilisant des packageages RPM. À l'heure actuelle, je suis coincé avec les anciennes versions de tomcat5-jsp-2.0-api et tomcat5-servlet-2.4-api-5.5.27-7.jpp5, car elles sont requirejses par jakarta-taglibs-standard: $ rpm -q –requires jakarta-taglibs-standard rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1 servletapi5 >= 0:5.0.16 tomcat5-jsp-2.0-api >= 0:5.0.16 […]

Erreur lors de la tentative de réinstallation du package rpm java

J'essaie de réinstaller java sur une boîte CentOS avec la command suivante (Est-ce la meilleure command?): rpm -i –force /root/jdk-6u11-linux-i586.rpm Mais j'ai des erreurs lorsque je fais ceci: Error: Could not open input file: /usr/java/jdk1.6.0_11/jre/lib/rt.pack jsse.jar… Error: Could not open input file: /usr/java/jdk1.6.0_11/jre/lib/jsse.pack charsets.jar… etc….. Quelqu'un sait pourquoi?