Articles of yum

mise à niveau de l'extension php

Depuis la mise à niveau de la version 5.0 vers 5.5, je reçois l'erreur suivante sur ma page PHP. Aucune des extensions PHP supscopes (MySQLi, MySQL, PDO_MySQL) n'est disponible. Lorsque j'ai essayé d'installer le package php–mysql, je reçois l'erreur suivante. # yum install php-mysql –skip-broken Packages skipped because of dependency problems: mysql-5.0.77-4.el5_4.2.x86_64 from base php-mysql-5.1.6-27.el5.x86_64 […]

php 5.3 et libxml2 cauchemar

My CentOS 5.7 est livré avec libxml2 2.6.26 qui est très désuet et cause également de nombreux problèmes avec mon PHP 5.3.3 actuel. J'ai besoin de mettre à jour la version de libxml2 à 2.7.8 ou au less 2.7.3+ j'ai lu beaucoup de messages, utilisé Google pour find une solution, mais je suis vraiment incapable […]

Erlang erreur d'installation sur Fedora 13

Je tente d'installer RabbitMQ sur une boîte Fedora 13. Cela nécessite que Erlang soit installé. Lorsque je lance yum install erlang je reçois les messages suivants. Yum semble indiquer qu'il a résolu toutes les dependencies, mais il ne manquait pas d'installer. Si j'utilise le –skip-broken comme je le suggère, rien n'est installé. Comment puis-je résoudre […]

Utilisez la command Fedora Yum après l'installation, comment configurer

Lorsque j'utilise la command "yum install exlipse *" après l'installation, affiche eclipse-cdt, mais dans eclipse ne peut pas éditer le projet C / C ++, ne pas effacer lorsque Yum après la configuration générale pour éclipser

Manipulation de la mise à niveau de yum de pkg-xyrpm qui nécessite mod_python vers pkg-x. (Y + z) .rpm avec les conflits mod_python

Avec yum / rpm sur RHEL 5, une yum upgrade à yum upgrade peut-elle être faite pour supprimer un autre package conflictuel – similaire au comportement de apt-get dist-upgrade sur Debian? Je suis en train de mettre à jour le programme .spec pour le rpm de notre produit. La version 4.2.x a utilisé mod_python, donc […]

Installez les problèmes PEAR Mail / Mime Dependence dans l'installation EPEL pure

Débutant dans la zone sysadm. Utilisation de Centos 6.2. J'essaie d'installer Mime.php de PEAR. J'ai déjà installé PEAR's Mail avant. Ce n'est pas bien pour Mime.php. C'est ce que je fais: yum install php-pear-Mail-Mime Problème de dépendance: Resolving Dependencies –> Running transaction check —> Package php-pear-Mail-Mime.noarch 0:1.8.2-1.el6 will be installed –> Processing Dependency: php-mbssortingng for […]

zlib / libxml2 duplicate package?

J'ai mis à jour mon micro instance amazon ec2 chaque mois jusqu'à maintenant. Lorsque j'essaie de "yum update", je reçois cette erreur: zlib-1.2.5-7.11.amzn1.x86_64 a installé les conflits libxml2 <('0', '2.7.7', Aucun): libxml2- 2.7.6 -4.12.amzn1.x86_64 zlib-1.2.5-7.11.amzn1.x86_64 est un duplicata avec zlib-1.2.3-27.9.amzn1.x86_64 eum update output: http://pastebin.com/Dfq0yphN J'ai essayé de mettre à jour séparément zlib et libxml2 zlib: […]

Problème de dépendance lors de l'installation de perl-Net-SNMP

Lorsque j'ai essayé d'installer perl-Net-SNMP , j'ai l'erreur de dépendance ci-dessous: # yum install perl-Net-SNMP … –> Processing Dependency: perl(Digest::HMAC) for package: perl-Net-SNMP-5.2.0-4.el6.noarch –> Processing Dependency: perl(Digest::SHA1) for package: perl-Net-SNMP-5.2.0-4.el6.noarch –> Finished Dependency Resolution Error: Package: perl-Net-SNMP-5.2.0-4.el6.noarch (epel) Requires: perl(Digest::HMAC) Error: Package: perl-Net-SNMP-5.2.0-4.el6.noarch (epel) Requires: perl(Digest::SHA1) You could try using –skip-broken to work around the […]

Erreur de compilation installant Nominatim

J'essaie d'installer Nominatim de sa source sur github . PostgreSQL 9.1 et PostGIS 2 ont déjà été installés à l'aide de yum . Le système utilise CentOS 6.3 avec cPanel. git clone –recursive https://github.com/twain47/Nominatim.git cd Nominatim ./autogen.sh git clone –recursive https://github.com/twain47/Nominatim.git git clone –recursive https://github.com/twain47/Nominatim.git cd Nominatim ./autogen.sh cd Nominatim git clone –recursive https://github.com/twain47/Nominatim.git cd […]

Erreur lors de l'installation de php-xml avec yum

Sur mon ancien server, j'ai utilisé php–xml pour générer des sitemaps xml. Sur mon nouveau server, j'ai découvert que php-xml n'est pas installé. J'ai fait 'yum install php-xml' mais j'ai l'erreur suivante: –> Running transaction check —> Package php-common.i686 0:5.2.17-1.el6.art will be updated –> Processing Dependency: php-common = 5.2.17-1.el6.art for package: php-mhash-5.2.17-1.el6.art.i686 —> Package php-devel.x86_64 […]