Mettre à niveau Shibboleth vers la dernière version sur Ubuntu

J'ai un server Web Ubuntu (12.04.4 LTS) exécutant Shibboleth 2.4.3

Je pense que Shibboleth a été installé en utilisant apt-get

dpkg --get-selections | grep shib libapache2-mod-shib2 install libshibsp5 install shibboleth-sp2-schemas install 

J'aimerais passer à Shibboleth 2.5.3 mais apt-get me dit que j'ai déjà eu la dernière version. Mais je ne le fais pas, par un long coup !!

Quelques conseils s'il vous plaît?


Une sortie supplémentaire après l'exécution de la mise à jour apt-get demandée

 apt-cache show libapache2-mod-shib2 Package: libapache2-mod-shib2 Priority: extra Section: universe/web Installed-Size: 826 Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com> Original-Maintainer: Debian Shib Team <pkg-shibboleth-devel@lists.alioth.debian.org> Architecture: amd64 Source: shibboleth-sp2 Version: 2.4.3+dfsg-2ubuntu1 Depends: libc6 (>= 2.14), libgcc1 (>= 1:4.1.1), liblog4cpp5, libmemcached6 (>= 0.44), libodbc1 (>= 2.2.11) | unixodbc (>= 2.2.11), libsaml7, libshibsp5, libstdc++6 (>= 4.6), libxerces-c3.1, libxmltooling5, adduser Recommends: apache2, openssl Conflicts: libapache2-mod-shib Filename: pool/universe/s/shibboleth-sp2/libapache2-mod-shib2_2.4.3+dfsg-2ubuntu1_amd64.deb Size: 254496 MD5sum: 72c2d318e6da4f163ea540c43dec64a9 SHA1: e8a29a347540aceba23db65783663f8e05c860ae SHA256: f0bc6495d3e2ecdadeb4019bba969aef166105500a6b372640a6546d65b11346 Description-en: Federated web single sign-on system (Apache module) The Shibboleth System is a standards based software package for web single sign-on across or within organizational boundaries. It supports authorization and atsortingbute exchange using the OASIS SAML 2.0 protocol. Shibboleth allows sites to make informed authorization decisions for individual access of protected online resources while allowing users to establish their identities with their local authentication systems. . This package contains the Shibboleth Apache module for service providers (web servers providing resources protected by Shibboleth) and the supporting shibd daemon. Homepage: http://shibboleth.internet2.edu/ Description-md5: 1b4d36e9224597e639627488183ac5dc Bugs: https://bugs.launchpad.net/ubuntu/+filebug Origin: Ubuntu 

EDIT 2.5.2 serait également acceptable pour passer à

2 Solutions collect form web for “Mettre à niveau Shibboleth vers la dernière version sur Ubuntu”

Switch.ch fournit un référentiel avec Shibboleth 2.5 pour les users de ubuntu 12.04, ici: https://www.switch.ch/aai/docs/shibboleth/SWITCH/2.5/sp/deployment/?os=ubuntu Vous devriez pouvoir append leur repository et téléchargez shibboleth 2.5 en procédant comme suit:

 sudo apt-get remove libshibsp5 sudo curl -k -O http://pkg.switch.ch/switchaai/SWITCHaai-swdissortingb.asc gpg --with-fingerprint SWITCHaai-swdissortingb.asc sudo apt-key add SWITCHaai-swdissortingb.asc echo 'deb http://pkg.switch.ch/switchaai/ubuntu precise main' | sudo tee /etc/apt/sources.list.d/SWITCHaai-swdissortingb.list > /dev/null sudo apt-get install shibboleth sudo mkdir -p /var/run/shibboleth sudo chown _shibd:_shibd /var/run/shibboleth sudo service shibd restart 

Confirmez la version de votre référentiel apt en exécutant ce qui suit:

 apt-get update apt-cache show packagename 
  • OpenVPN Désactiver la route mais autoriser le pont
  • Comment importer le file postgresql sur Linux avec un espace dans le path d'access?
  • Balance de charge Postifix SMTP
  • La connection https Ubuntu Apache prend beaucoup de time
  • Comment puis-je me connecter au server dans ubuntu à l'aide du file .ppk?
  • RAID iostat affichant 0.00 pour l'attente et% util
  • Marionnettes et modules, ne se fait-il pas beaucoup?
  • Bloc de security SSH tunnel Ubuntu (toujours en place)
  • Quels outils sont disponibles pour simuler certaines conditions de réseau sur Ubuntu?
  • monitor / stream bash_history
  • RabbitMQ limité à un esclave
  • Les astuces du serveur de linux et windows, tels que ubuntu, centos, apache, nginx, debian et des sujets de rĂ©seau.