Mettre à niveau Ubuntu 9.10 à 10.04

J'ai un tas d'anciennes machines en production qui fonctionnent avec uBuntu 9.10. Je souhaite maintenant mettre à niveau ces distributions 10.04 mais je reçois l'erreur suivante (parce que les dépôts ont expiré je suppose)

The following packages have unmet dependencies: update-manager-core: Depends: python-apt (>= 0.7.5) but it is not going to be installed E: Broken packages 

Toutes mes commandes de mise à jour de apt-get update / apt-get échouent avec erreur

 Ign http://security.ubuntu.com jaunty-security Release.gpg Ign http://us.archive.ubuntu.com jaunty Release.gpg Ign http://us.archive.ubuntu.com jaunty-updates Release.gpg Ign http://security.ubuntu.com jaunty-security Release Ign http://us.archive.ubuntu.com jaunty Release Ign http://security.ubuntu.com jaunty-security/main Packages Ign http://us.archive.ubuntu.com jaunty-updates Release Ign http://security.ubuntu.com jaunty-security/restricted Packages Ign http://security.ubuntu.com jaunty-security/main Sources Ign http://security.ubuntu.com jaunty-security/restricted Sources Ign http://us.archive.ubuntu.com jaunty/main Packages Ign http://us.archive.ubuntu.com jaunty/restricted Packages Ign http://us.archive.ubuntu.com jaunty/main Sources Ign http://us.archive.ubuntu.com jaunty/restricted Sources Ign http://us.archive.ubuntu.com jaunty/universe Packages Ign http://security.ubuntu.com jaunty-security/main Packages Ign http://security.ubuntu.com jaunty-security/restricted Packages Ign http://security.ubuntu.com jaunty-security/main Sources Ign http://us.archive.ubuntu.com jaunty/universe Sources Ign http://us.archive.ubuntu.com jaunty-updates/universe Packages Ign http://us.archive.ubuntu.com jaunty-updates/universe Sources Ign http://us.archive.ubuntu.com jaunty/main Packages Ign http://us.archive.ubuntu.com jaunty/restricted Packages Ign http://us.archive.ubuntu.com jaunty/main Sources Ign http://security.ubuntu.com jaunty-security/restricted Sources Err http://security.ubuntu.com jaunty-security/main Packages 404 Not Found [IP: 91.189.92.166 80] Ign http://us.archive.ubuntu.com jaunty/restricted Sources Ign http://us.archive.ubuntu.com jaunty/universe Packages Err http://security.ubuntu.com jaunty-security/restricted Packages 404 Not Found [IP: 91.189.92.166 80] Err http://security.ubuntu.com jaunty-security/main Sources 404 Not Found [IP: 91.189.92.166 80] Err http://security.ubuntu.com jaunty-security/restricted Sources 404 Not Found [IP: 91.189.92.166 80] Ign http://us.archive.ubuntu.com jaunty/universe Sources Ign http://us.archive.ubuntu.com jaunty-updates/universe Packages Ign http://us.archive.ubuntu.com jaunty-updates/universe Sources Err http://us.archive.ubuntu.com jaunty/main Packages 404 Not Found [IP: 91.189.92.171 80] Err http://us.archive.ubuntu.com jaunty/restricted Packages 404 Not Found [IP: 91.189.92.171 80] Err http://us.archive.ubuntu.com jaunty/main Sources 404 Not Found [IP: 91.189.92.171 80] Err http://us.archive.ubuntu.com jaunty/restricted Sources 404 Not Found [IP: 91.189.92.171 80] Err http://us.archive.ubuntu.com jaunty/universe Packages 404 Not Found [IP: 91.189.92.171 80] Err http://us.archive.ubuntu.com jaunty/universe Sources 404 Not Found [IP: 91.189.92.171 80] Err http://us.archive.ubuntu.com jaunty-updates/universe Packages 404 Not Found [IP: 91.189.92.171 80] Err http://us.archive.ubuntu.com jaunty-updates/universe Sources 404 Not Found [IP: 91.189.92.171 80] W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/main/binary-i386/Packages.gz 404 Not Found [IP: 91.189.92.166 80] W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/restricted/binary-i386/Packages.gz 404 Not Found [IP: 91.189.92.166 80] W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/main/source/Sources.gz 404 Not Found [IP: 91.189.92.166 80] W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/jaunty/main/binary-i386/Packages.gz 404 Not Found [IP: 91.189.92.171 80] W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/jaunty/restricted/binary-i386/Packages.gz 404 Not Found [IP: 91.189.92.171 80] W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/jaunty/main/source/Sources.gz 404 Not Found [IP: 91.189.92.171 80] W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/jaunty-security/restricted/source/Sources.gz 404 Not Found [IP: 91.189.92.166 80] W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/jaunty/restricted/source/Sources.gz 404 Not Found [IP: 91.189.92.171 80] W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/jaunty/universe/binary-i386/Packages.gz 404 Not Found [IP: 91.189.92.171 80] W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/jaunty/universe/source/Sources.gz 404 Not Found [IP: 91.189.92.171 80] W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/jaunty-updates/universe/binary-i386/Packages.gz 404 Not Found [IP: 91.189.92.171 80] W: Failed to fetch http://us.archive.ubuntu.com/ubuntu/dists/jaunty-updates/universe/source/Sources.gz 404 Not Found [IP: 91.189.92.171 80] E: Some index files failed to download, they have been ignored, or old ones used instead. 

Quelqu'un peut-il m'aider avec les prochaines étapes et comment je peux réparer cela. S'il y a un PPA ou tout autre dépôt conservant update-manager-core avec toutes les dépendances, je suis heureux d'utiliser cela.

Merci Sparsh Gupta

Dans le cas où LucidUpgrades ne fonctionne plus, allez directement de Jaunty à Lucid et sautez Karmic. Faire une sauvegarde de données précieuses d'abord,
En tant que course racine:

 cd /etc/apt perl -i.bak -pe 's/jaunty/lucid/' sources.list aptitude update aptitude dist-upgrade