Où se trouve le repository yum pour emacs 23 pour CentOS 5.5?

Je souhaite mettre à jour mon emacs sur CentOS 5.5 à 23, mais je ne trouve aucun rpms ou yum repos qui l'ont?

J'ai passé un peu de time à essayer de créer des emacs sur RHEL5.7, en vain. Puis, revenir au google, et j'ai trouvé un count avec emacs23 RPM pour CentOS / RHEL 5.x.

http://puias.princeton.edu/data/puias/unsupported/5.7/x86_64/

Pour l'utiliser, utilisez Emacs21 pour créer un file text dans /etc/yum.repos.d/puias-unsupported.repo .
Il devrait avoir ces contenus:

 [puias-unsupported] name=PUIAS Unsupported $releasever baseurl=http://puias.princeton.edu/data/puias/unsupported/5/$basearch/ enabled=0 gpgcheck=0 

Ensuite, utilisez-le comme ceci:

sudo yum –disablerepo = "*" –enablerepo = puias-installation non prise en charge emacs23

Les RPM sont:

  • Emacs23-23.2-5.x86_64.rpm
  • emacs23-common-23.2-5.x86_64.rpm

Si vous l'installez de cette façon, il sera placé dans /usr/emacs23/ . Il ne remplace pas les emacs21 existants.

Il existe également une version nox de emacs23 dans ce count. Et un tas d'autres choses.

De plus, pour que cela fonctionne correctement et afin de prévenir les avertissements, j'ai fait ce qui suit:

cd / usr / share / emacs /

ln -s /usr/emacs23/share/emacs/23.2

mkdir 23.2 / leim

mkdir -p /usr/libexec/emacs/23.2/x86_64-redhat-linux-gnu

Vous pouvez récupérer les RPMS source depuis une version récente de Fedora (ou RHEL6) et les rebuild vous-même.

La dernière version d'Emacs sur RHEL5 est 21. Essentiellement, RHEL / CentOS est destiné au marché des servers d'entreprise, qui est beaucoup plus préoccupé par la stabilité que par la fonctionnalité de saignement.

Voir cette autre publication pour plus d'explications.

– Chrytopher Karel