OSX Yosemite IP Forwarding ne fonctionne pas

Je ne parviendrais pas à configurer le transfert ip de base sur OSX Yosemite 10.10.1 Mac-Mini.

J'utilise exactement la même configuration sur un OSX Mavericks 10.9.5 Mac-Mini, et ça fonctionne parfaitement?

J'ai mis le

sudo sysctl -w net.inet.ip.forwarding=1 sudo sysctl -w net.inet6.ip6.forwarding=1 sudo sysctl -w net.inet.ip.fw.enable=0 

J'utilise deux interfaces

un sur le réseau avec la passerelle vers Internet en0:

 ip 192.168.7.7 gateway : 192.168.7.254 

un à usage local seulement en5 (usb to ethernet)

 ip 192.168.54.254 gateway : self 

Je configure un DHCP sur l'en5 pour la livraison de l'ip

 192.168.54.0/24 

Je configure la route statique sur mon routeur (192.168.7.254)

 Destination 192.168.54.0/24 -> 192.168.7.7 

Lorsqu'un périphérique est connecté sur l'interface en5

  • ils obtiennent un bon ip de dhcp (192.168.54.x)
  • ils peuvent faire une interface ping en5

    ping 192.168.54.254 // ok

  • ils peuvent faire une interface ping en0

    ping 192.168.7.7 // ok

  • Mais je n'arrivais pas à contacter une autre machine sur le réseau 192.168.7.x, ou n'importe quel IP de l'extérieur.

    ping 192.168.7.254 // timeout

Voici ma table de route

 Destination Gateway Flags Refs Use Netif Expire default 192.168.7.254 UGSc 45 0 en0 default link#5 UCSI 0 0 en5 127 127.0.0.1 UCS 0 0 lo0 127.0.0.1 127.0.0.1 UH 3 805 lo0 169.254 link#4 UCS 0 0 en0 169.254 link#5 UCSI 0 0 en5 192.168.6/23 link#4 UCS 5 0 en0 192.168.6.41 b8:27:eb:4:a6:63 UHLWI 0 1 en0 751 192.168.7.3 0:11:32:2:e0:4b UHLWI 0 82 en0 574 192.168.7.7/32 link#4 UCS 0 0 en0 192.168.7.13 14:10:9f:e1:7a:cb UHLWIi 3 6587 en0 170 192.168.7.70 4c:72:b9:64:1:f6 UHLWI 0 1 en0 1072 192.168.7.75 10:9a:dd:4b:a3:16 UHLWI 0 0 en0 662 192.168.7.254/32 link#4 UCS 2 0 en0 192.168.7.254 0:50:7f:3a:31:c7 UHLWIir 46 3 en0 1151 192.168.54 link#5 UCS 1 0 en5 192.168.54.1 a8:20:66:15:50:74 UHLWIi 1 9 en5 167 192.168.54.254/32 link#5 UCS 0 0 en5 

PF est désactivé

Une fois encore, j'ai exactement la même configuration sur un mac mini sur OS 10.9.5 et ça marche, le renvoi d'IP a le comportement classique …

Merci pour l'aide.