PHP 5.4 ne peut pas inclure le file avec permissions 777

Je travaille sur la configuration de PHP 5.4, et j'ai mis une bibliothèque dans /usr/share/php/ J'ai défini include_path='.:/usr/share/php' et je n'ai pas pu inclure quoi que ce soit avec un besoin relatif requirejs_une fois.

J'ai configuré l'inclusion dans le path explicite et obtenez une erreur d'autorisation, même après avoir chmod le file sur 777 .

 failed to open stream: Permission denied 

Est-ce qu'il me manque quelque chose?

MODIFIER

Voici les permissions pour le file que j'essaie d'inclure:

 /usr/share/php drwxrwxrwx. 64 1001 1001 4096 Sep 29 2011 Zend /usr/share/php/Zend/ -rwsrwsrwt. 1 1001 1001 12959 Mar 1 2011 Config.php / usr / share / php /usr/share/php drwxrwxrwx. 64 1001 1001 4096 Sep 29 2011 Zend /usr/share/php/Zend/ -rwsrwsrwt. 1 1001 1001 12959 Mar 1 2011 Config.php drwxrwxrwx. /usr/share/php drwxrwxrwx. 64 1001 1001 4096 Sep 29 2011 Zend /usr/share/php/Zend/ -rwsrwsrwt. 1 1001 1001 12959 Mar 1 2011 Config.php 64 1001 1001 4096 29 sept. 2011 Zend /usr/share/php drwxrwxrwx. 64 1001 1001 4096 Sep 29 2011 Zend /usr/share/php/Zend/ -rwsrwsrwt. 1 1001 1001 12959 Mar 1 2011 Config.php / usr / share / php / Zend / /usr/share/php drwxrwxrwx. 64 1001 1001 4096 Sep 29 2011 Zend /usr/share/php/Zend/ -rwsrwsrwt. 1 1001 1001 12959 Mar 1 2011 Config.php 

Et les deux ont besoin de lignes que j'ai essayé:

 require_once('/usr/share/php/Zend/Config.php'); require_once('Zend/Config.php'); require_once ('/ usr / share / php / Zend / Config.php'); require_once('/usr/share/php/Zend/Config.php'); require_once('Zend/Config.php'); 

Vérifiez si vous avez une autorisation d'exécution sur le dossier dans lequel votre lib est assis, vous devez activer Apache (ou tout autre server Web que vous utilisez) avec l'autorisation d'exécution sur le dossier contenant les files que vous souhaitez inclure / exiger