Probelms Intstalling Trac utilisant apt-get Ubuntu Jaunty

J'ai des problèmes pour installer correctement Trac sur mon Ubuntu Jaunty Box.

En utilisant la command 'apt-get install trac', je reçois la sortie suivante:

root@myserver:~# apt-get install trac Reading package lists... Done Building dependency tree Reading state information... Done Some packages could not be installed. This may mean that you have requested an impossible situation or if you are using the unstable dissortingbution that some required packages have not yet been created or been moved out of Incoming. Since you only requested a single operation it is extremely likely that the package is simply not installable and a bug report against that package should be filed. The following information may help to resolve the situation: The following packages have unmet dependencies: trac: Depends: python-setuptools (> 0.5) but it is not installable Depends: python-pysqlite2 (>= 2.3.2) but it is not going to be 

installé Dépend: python-subversion mais il n'est pas installé Dépend: libjs-jquery mais il n'est pas installé Recommand: python-pygments (> = 0.6) mais il n'est pas installable ou inscripble, mais il n'est pas installé Recommand: python-tz mais it n'est pas installable E: packages cassés

J'ai utilisé avec succès la command sur ma machine de bureau karmic kola et je suis capable de créer de nouveaux projets, etc.

Je pensais pouvoir résoudre le problème en installant toutes les extensions liées à Python. Cela a produit une sortie très similaire.

J'ai des référentiels principaux, universels et multi-versets activés. C'est une machine à distance et je n'ai pas access au gui.

J'espère que quelqu'un peut aider, Google n'a pas réussi à résoudre le problème ou à find une solution!

Merci,

Ben

4 Solutions collect form web for “Probelms Intstalling Trac utilisant apt-get Ubuntu Jaunty”

Ce type de rupture de dépendance n'a pas de sens. Les versions auxquelles le message d'erreur se plaint sont disponibles dans Jaunty (par exemple, version 0.6c9 de python-setuptools ).

Je vérifierais /etc/apt/sources.list et /etc/apt/sources.list.d/*.list , et assurez-vous que le même miroir est en train de devenir principal, universel et multivoire pour une security rapide et sûre, et jaunty-updates.

Vous pourriez essayer de faire le dangereux

apt-get update; apt-get upgrade

pour get tous les packages sur la même version.

Bien qu'une installation de la source soit plus sûre: http://trac.edgewall.org/wiki/TracInstall

Jeroen

Avez-vous essayé d'utiliser easy_install.

Voir la documentation http://trac.edgewall.org/wiki/TracInstall

Avez-vous plus d'une version de python installée sur ce système? J'ai vu des rapports de problèmes similaires où il s'avère que les modules nécessaires sont installés pour une seule version de python et que le server Web utilise une version différente. Cela peut se produire avec 32 bits vs 64 bits, ou 2,4 vs 2,5, etc.

  • Sendmail sur Ubuntu essayant d'utiliser les servers Google Apps comme un relais par défaut?
  • vsftpd chroot_local_user ne fait rien
  • Impossible de limiter les connections avec Iptables: "Aucune string / cible / correspond à ce nom".
  • Du file journal au terminal en time réel
  • Comment créer un server hot swap utilisant Linux
  • Obtenez de l'ip flottant de mmm pour travailler sur Tinc vpn sur Ubuntu
  • kadmind error - krb5_recvauth: start_seq_get n'est pas pris en charge dans le type de key de type HDBGET
  • Bloquer plusieurs requêtes sur un file supprimé
  • Migrer une VM Ubuntu sur virsh vers un server hyperv 2012
  • Problèmes de démarrage HP Microserver
  • Ubuntu 10.4 Installation minimale du server Lucid: défilement du terminal lent
  • Les astuces du serveur de linux et windows, tels que ubuntu, centos, apache, nginx, debian et des sujets de rĂ©seau.