Qu'est-ce que l'on veut dire / sbin / init trop ancien?

J'essaie d'utiliser Upstart pour démembrer un script. Donc, j'ai fait un file .conf sous /etc/init/ . Maintenant, pour vérifier le file Conf, j'ai fait

 init-checkconf /etc/init/ping_me.conf 

Et il dit

 ERROR: version of /sbin/init too old 

Ma version kernel de linux est 3.19.0-20-generic .

L'Upstart est incapable de configurer le service. Par conséquent, le service ping_me start ne fonctionne pas. Donc, si init peut être mis à jour, comment puis-je le mettre à jour?

C'est parce que, sur Ubuntu 15.04, /sbin/init n'est PAS UPSTART .

Upstart est à /sbin/upstart .

Par défaut, 15.04 utilise Systemd au lieu de * Upstart *.

Vous devriez plutôt searchr un file unité Systemd .

Voir: https://wiki.ubuntu.com/SystemdForUpstartUsers