RHEL5 – Impossible de mettre à jour les packages en raison de i386 rpm en conflit avec x86_64 rpm

Lorsque vous essayez d'exécuter la mise à jour yum, je reçois les erreurs suivantes:

Downloading Packages: Running rpm_check_debug Running Transaction Test Finished Transaction Test Transaction Check Error: file /usr/lib/rpm/macros from install of rpm-4.4.2.3-36.el5_11.x86_64 conflicts with file from package rpm-4.4.2.3-36.el5_11.i386 file /usr/lib/rpm/noarch-linux/macros from install of rpm-4.4.2.3-36.el5_11.x86_64 conflicts with file from package rpm-4.4.2.3-36.el5_11.i386 file /usr/share/man/man8/pam_sss.8.gz from install of sssd-client-1.5.1-71.el5.x86_64 conflicts with file from package sssd-client-1.5.1-70.el5.i386 file /usr/share/man/man8/sssd_krb5_locator_plugin.8.gz from install of sssd-client-1.5.1-71.el5.x86_64 conflicts with file from package sssd-client-1.5.1-70.el5.i386 Error Summary ------------- 

J'ai essayé de forcer les packages individuels à être mis à jour mais je n'ai pas eu de chance. Quelqu'un peut-il m'aider à résoudre ce problème? Il ressemble à des packages x86_64 et les packages i386 sont des têtes de butting. Cela a été exécuté avec le jeu de drapeaux brisé.

2 Solutions collect form web for “RHEL5 – Impossible de mettre à jour les packages en raison de i386 rpm en conflit avec x86_64 rpm”

Je pense que c'est mieux si vous utilisez le nom complet du package dans ce cas

 yum remove rpm-4.4.2.3-36.el5_11.i386 

et

 yum remove sssd-client-1.5.1-70.el5.i386 

supprimer les packages en conflit:

yum remove rpm sssd-client

puis les installer:

yum install rpm sssd-client

  • Impossible d'installer php-mssql sur CentOS 5
  • Installled Jetty via Yum (CentOS), mais ne peut pas find start.jar pour l'exécuter
  • Comment installer php 5.2.17 sur centos 6 x86_64
  • Comment mettre à niveau une machine RHEL vers une version plus récente, mais pas la plus récente?
  • CentOS yum remove postgres ne fonctionne pas
  • Problème d'installation de php-devel sur CentOS 6
  • Impossible d'installer un package à l'aide de yum
  • Erreur de marionnettes sur le package déjà installé sur centos
  • yum supprimer * wildcard *, à l'exception de certains packages qui ont également correspondu au caractère générique?
  • Comment puis-je voir quelle est la dernière version d'un package disponible dans un count de rechange spécifique si j'ai déjà installé / mis à jour un autre post?
  • Quelle est la différence entre `yum groupinstall` vs regular` yum install`?
  • Les astuces du serveur de linux et windows, tels que ubuntu, centos, apache, nginx, debian et des sujets de rĂ©seau.