Ruby 1.8.7 sur Plesk 9.5.4

J'essaie d'installer Ruby 1.8.7 sur Plesk 9.5.4. Je lance actuellement 1.8.6 mais gem exige une version plus récente de Ruby à installer:

 /opt/ruby/bin/gem update --system Updating RubyGems Updating rubygems-update ERROR: While executing gem ... (Gem::InstallError) rubygems-update requires Ruby version >= 1.8.7 

Une application que j'essaie d'installer nécessite i18n mais qui ne peut pas être installée car gem n'est pas à jour:

 /opt/ruby/bin/gem install -v=0.4.2 i18n ERROR: Error installing i18n: i18n requires RubyGems version >= 1.3.5 

Toute aide serait grandement appréciée!

OS: Red Hat Enterprise Linux version 4 (Nahant Update 6) Kernel: 2.6.9-67.EL (ancien, je sais …)

Supprimez la version binary de Ruby, obtenez la source et installez avec: ./configure , make , sudo make install . Après cela, vous pouvez également get le code source RubyGems et installer avec /usr/local/bin/ruby setup.rb .