SharePoint 2013, Server 2012, la binding d'adresse IP d'IIS génère 404

J'ai récemment essayé de configurer SSL dans SharePoint 2013. Il fonctionnait très bien en utilisant un cerat générique, des en-têtes d'hôte et une binding à All Unassigned. Cependant, j'ai maintenant besoin d'un autre cert dans le mix, donc je ne peux pas avoir deux certs différents sur All Unassigned et je dois plutôt me lier aux adresses IP.

Le problème est que chaque application Web SharePoint génère un 404 si son site IIS est affecté à une adresse IP. Fonctionne bien Tout Non atsortingbué, toujours 404 lorsqu'il est sur une IP.

J'ai testé la création d'un site IIS sans SharePoint. Fonctionne bien dans tous les cas, aucun 404 pour tous non affectés et liés à une adresse IP.

J'ai testé la fermeture d'un IIS SharePoint et j'utilise son nom d'hôte sur le site IIS ordinaire, donc je sais que ce n'est pas un problème DNS … le nom d'hôte fonctionne très bien et se dirige correctement vers le site IIS approprié, "Tous non atsortingbués" ou liés à une adresse IP.

J'ai également testé tout cela sans SSL. SSL n'est pas le coupable non plus. Le même comportement exact appartient aux sites SharePoint uniquement configurés pour HTTP régulier. Works All Unassigned, toujours 404 quand il est lié à une adresse IP.

Lorsque le 404 se produit, les journaux ULS de SharePoint s'affichent:

Reached maximum number of failed machines based on ping results for this routing group Mapping URI https://myhostname to https://myserversname 

Étant donné que les journaux ULS montrent «tout», je sais que la request est effectuée par IIS et dans SharePoint, il doit donc s'agir d'un problème SharePoint.

Je suis perplexe. N'avez-vous pas trouvé de mention de ce problème n'importe où après avoir passé des heures à bash les moteurs de search, essayer ici, Stack Overflow, etc. J'ai même essayé de reproduire ceci dans une de mes machines virtuelles SharePoint 2013 de développement, mais tout a fonctionné comme expectoré. N ° 404 lors de la messagerie avec les bindings IP Address. Je viens tout juste de faire la même chose à un server SharePoint SharePoint 2010, et encore une fois, tout a fonctionné comme prévu. Tous les sites IIS liés à l'adresse IP sont entièrement accessibles. Cela semble être cette installation particulière de SharePoint 2013 sur ce server particulier.

En espérant que quelqu'un a une idée du problème. Je n'ai pas encore trouvé de cas documenté. J'ai utilisé les noms d'hôtes dans DNS, les bindings IIS sur ce server, les bindings IIS sur d'autres servers, la création de sites de test utilisant les mêmes noms d'hôte et les bindings IP, etc. depuis des jours et, dans tous les cas, le problème ne se produit pas tout autre server, mais cette installation spécifique de SharePoint.

Merci.

Eh bien, j'ai abordé le problème. La désactivation du service de gestion des requêtes dans Central Admin permet à tout de fonctionner comme prévu. Je peux maintenant lier n'importe lequel de mes sites à leurs propres adresses IP très bien sans 404s.

Je pense que si cette réponse résout mon problème immédiat, elle ne répond pas à ce qui ne va pas avec le service de gestion des requests qui causait cela. Ou simplement, je ne comprends pas pour quoi le service de gestion des requests est réellement utilisé, et il n'a jamais été activé en premier lieu. Et bien sûr, le service de gestion des requests est également désactivé sur mes autres environnements SharePoint 2013. Tout fonctionnait comme prévu.