Zend 1 sur Ubuntu avec MSSQL ne fonctionnant pas

Est-ce que quelqu'un sait comment résoudre le problème suivant? Sinon, est-ce que quelqu'un sait comment configurer Zend 1 sur Linux pour communiquer avec le server msSQL?

Nous obtenons l'erreur suivante dans les journaux nginx lors de l'utilisation de freetds et de l'adaptateur pdo_dblib. Nous utilisons Zend 1.2 sur Ubuntu 12.04 en utilisant nginx 1.2.7

2013/02/27 20:48:24 [error] 9057#0: *28 FastCGI sent in stderr: "PHP message: PHP Warning: include_once(Zend/Db/Adapter/Pdo/Dblib.php): failed to open stream: No such file or directory in /www/development/library/Zend/Loader.php on line 146 PHP message: PHP Warning: include_once(): Failed opening 'Zend/Db/Adapter/Pdo/Dblib.php' for inclusion (include_path='/www/development/application/../library:/www/development/library:.:/usr/share/php:/usr/share/pear') in /www/development/library/Zend/Loader.php on line 146 PHP message: PHP Warning: include_once(Zend/Db/Adapter/Pdo/Dblib.php): failed to open stream: No such file or directory in /www/development/library/Zend/Loader.php on line 146 PHP message: PHP Warning: include_once(): Failed opening 'Zend/Db/Adapter/Pdo/Dblib.php' for inclusion (include_path='/www/development/application/../library:/www/development/library:.:/usr/share/php:/usr/share/pear') in /www/development/library/Zend/Loader.php on line 146 PHP message: PHP Fatal error: Uncaught exception 'Zend_Exception' with message 'File "Zend/Db/Adapter/Pdo/Dblib.php" does not exist or class "Zend_Db_Adapter_Pdo_Dblib" was not found in the file' in /www/development/library/Zend/Loader.php:99 Stack trace: 0 /www/development/library/Zend/Db.php(263): Zend_Loader::loadClass('Zend_Db_Adapter...') 1 /www/development/library/Zend/Application/Resource/Db.php(142): Zend_Db::factory('PDO_DBLIB', Array) 2 /www/development/library/Zend/Application/Resource/Db.php(154): Zend_Application_Resource_Db->getDbAdapter() 3 /www/development/library/Zend/Application/Bootstrap/BootstrapAbstract.php(680): Zend_Application_Resource_Db->init() 4 /www/development/library/Zend/Application/Bootstrap/BootstrapAbstract.php(623): Zend_Application_Bootstrap_BootstrapAbstract->_executeResource('db') 5 /www/development/library/Zend/Application/Bootstrap/BootstrapAbstract.php(583): Zend_Application_Bootstrap_BootstrapAbstract->_bootstrap(NULL) 6 /www/development/library/Zend/Appli" while reading response header from upstream, client: 108 

Nous avons essayé ceci et ce tutoriel.

Ceci est plus une question StackOverflow que ServerFault. Vérifiez le réglage de votre adaptateur, il doit probablement être Pdo_Mssql.